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w Advanced movie making in 3dmod .

If you have NOT made movies of your data using 3dmod before, we advise
you to first follow the tutorial: “Making Movies of 3D Models using IMOD”,
to help you understand the basic principles of making movies in 3dmod.

Producing a “mixed” series of model and zap images

1. Open 3dmod, select your image file and model file. Click OK.

B 3dmod Startup - O X
Start program as
Use cache, set to: + Sections " Megabytes
" 2dmod - open Info and image windows &
" 3dmodv - open Model View window only I"" Cache images as tiles or strips
I™ Fill cache upon startup
Image file()f | magefie Select...
I Image files form a pyramid at multiple resolutions
Model fie: | Moviefie] I Select.. | [ Flip ¥ and 2 sizes by rotating around X

Piece fie(s): | select... | I Load non-byte data in as 16-bit integers

Al

Angle file: | Select... I Show RGE images as grayscale

["" Load single-mage files as separate times, not sections
I™ Piece file is a metadata autodoc (.mdoc) file

I”" Load mon
Load image subset (numbered from 0} Open I Load model wi
X from: to [ %¥Z window I"" Load FFT without mirroring data on left side

¥ from: to: ™ mode! view I~ how images ssmontage |1 —J inXby T Ay
Z from: to: V¥ zap window Over x: |4 El: nY: |4 El:
ow size

I™ Slicer
Bnby [1 = Xy, [1 = inzZ
Scale image intensities: o0, to 255

When files must be scanned to find scaling

@ Do full scan for true min and max
" Scan subset to estimate min and max
" Scan subset to estimate mean and SD

I Modify MRC file header with values from scan

2. In the main 3dmod window, select the directory you want the
“snaps” (images) to go to.

@ 3dmod: nodules...  — O >

File > Set Snap Dir...
File Edit Image Special Help

Mew Model 1_modelv1#autosave

Open Model . Create a folder just for the movie snaps.

o : ,, : .
Reload Model e Call it “Movie Snaps” or something similar.
Save Model 5

(Y [2a =] /oo Then:

Save Model As..,

Write Model as  » [(J1Z1%8 = [o0n Select Folder
— Mode

Movie/Montage...

_— : - & Movi
Set Snap Dir... | 255 oviE

Gray TIF Snaps Auto| | © Model
L ETIIT 0 sections.

Extract File...

Process File...

Save Info Text...

Chuit
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3. Open model view: Image > Model View (or just V)

3dmeod: nodules., — O o
File Edit | Image S5Special Help
nodule  ZaP z Ve
“a| - Multi-Z
AT Ctrl+x
Object | i { 4536
Slicer )
Contour | J 5195

Linked Slicers

Point 100
| Point | Model View V /

Black ——  Pixel View i

White = Graph Shift+G [V

[ Float Locator lodel
[TTEEESEET |spsurface Shift+L —;|

3dmod 4.9, Turnbler

Regents of : : z‘

model (or use HotKeys menu) out to a comfortable zoom factor for
—_— both data and model. oo e
Model Editing = B = : \ “
— T - > 7 i‘f}J
& 3dmodv Movie: no..  — m} >

Full 3680 X | Full 360 Y |I— Long way 7 T|Ck Write files
6. Tick Z (to hide image) Set Start | Set End ||— Reverse

. . |— . | . X Rotation .
Go to File > Movie/Montage TR — el .O(;oen the Sequence
. [3115 [3115 ZRotation window
(Or JUSt M) |-1839 |-1839 X Translation

@ 3dmod Model View: nodules34flip_ali_trim1_modelv1 - o X

| -2982 |-2982 ¥ Translation TIP: you m|ght

| File Edit View Hotkeys Help |59 |59 Z Translation
e Mone |511.5 |511,5 Zoom Factor want to Change
[1 [1 X Slice
E [+ Y sice the file type to
Snap NonT As... |51 |51 7 Slice
Zero Snap File # |0 | 0 Transparen .J P E G S.
Set Snap Dir... ]
| MovierMontage.. M| |1 It Thickness
Movie Sequence... N '10— # of movie frames B 3dmodv Movie Sequencer..  — O x

Close Ctrl+Q

Actions that modify the table

2 3’ # of montage frames in 4E5Y Add After ‘ Add Before | Replace ‘ Delete |

Make Save as Actions that use settings in current table segment

* Movie {+ TIFFs m FPs = asTovie | ZEE | ferwEnd ‘

" Montage | | IPEGs # Frames | View #| Label [

[
~
¥ wirite files — I Sequence... I
Make | Stop | Done | Help |

Run Al Save Load Done Help




9. In the Movie/Montage window, change the # of movie frames to
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match the number of z stacks you want to use, then click on Full 360 X.

& 3dmodv Movie: ne..  — O X
Full 360 X Ful 380y | [ Long way
Set Start Set End I Reverse

|-76.3 |-76.8 X Rotation
| 152.2 | 182.2 ¥ Rotation
[-31.15 |-31.15 Z Rotation
[-1839 [-1830 ¥ Translation
|-2062 |-2982 ¥ Translation
| -59 | -59 Z Translation
|511.5 |511.5 Zoom Factor
[1 [1 X Slice
|1 [1 ¥ Slice
| 100 | 100 7 Slice
| o |D Transparency
| i | i Thickness
| 100 # of movie frames I
2 3: # of montage frames in X &Y
Make Save as
* Movie * TIFFs 20 3: FPg
" Montage " IPEGs
W it fles | PGS Sequence...
Make ‘ Stop | Done | Help |

15. In the Sequence window, click Add After. A
number 1 should appear in the column on the left
showing the number of Frames of 1 view each,
with Full 360 X as a Label.

@ 3dmodv Movie Sequencer.. — O *

i odify the table
Add After |§ Add Before | Replace | Delete |

Actions that use settings in current table segment

Use as Movie | Set to Start | Set to End |
# Frames | View # | Label
1 10 1| Full 360 X
Run All | Save | Load | Done | Help |

10. In the Movie/Montage window, click on Full 360 Y.

|-1839 [-1839 X Translation

|-2962 [-2962 ¥ Translation

| -58 | -59 Z Translation

|511.5 [5115 Zoom Factor

|1 [1 % Slice

1 [1 ¥ slice

[ 100 [100 7 slice

| a | i} Transparency

| 1 | 1 Thickness
100 # of movie frames

2 El: # of montage frames in X &Y
Make Save as

i+ Movie + TIFFs 20 El: FPS

" Montage " JPEGs
¥ Write files " PNGs Sequence...

Make | Stop | Done | Help |

@emeeree o 2 |13, In the Sequence window, click Add After. A
Ful 360X l Full 360 Y I Long way number 2 ShOUId appear in the Column on the Ieft

Set Start | SetEnd I Reverse
I showing the number of Frames of 1 view each, with

[3i [51s  zeosten Full 360 Y as a Label.

B 2dmodv Movie Sequence...  — O .

Action= that ﬂrdif’y the table
Add After | Add Before | Replace | Delete |

Actions that use settings in current table segment

Use as Muvie| Set to Start | Set to End |
# Frames | View # | Label |
1 10 1/ Full 360 X
2 10 1| Full 360 Y

Run .ﬁ.II| Save | Load | Done | Help |
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11. In the Sequence window, click Run All.
:
Now check that the image sequence was saved 2
in the folder you set as Snap Directory. If the 3
folder is empty, make sure you did step 2, and
Write files is ticked, then repeat Run All.

# Frames | View # | Label |
100 1
100 1 Full 360y
100 1| Full 360 X
Feun All Save | Load | Done | Help |

12. Clear the Sequence window by deleting both movie schedules

@ 3dmodv Movie Sequencer.,  — [m| x

Delete |

Actions that use settings in current table segment

Actions that modify the table
Add After | Add Before | Replace

Use as Movie | Set to Start | Set to End |
# Frames | View | Label |
Run Al | Save | Load | Daone | Help |

Suggestion: use higher
resolution for better

quality videos!
You can always compress
them later.

13. Press Z to overlay
the image on the
model.

Go to Edit > Image

. 3dmod Model View: nodules34flip_ali_trim1_modelv1

File | Edit View HotKeys Help
Objects... Shift+0
Centrols... Shift+C
Rotation... Shift+R
Object List... Shift+L
Background...  Shift+B
Models... Shift+M
Views... Shift+V
Isosurface... Shift+U

_W©

Bad. - m] X

I View X image
I view Y image
¥ view Z image

I
=
X

I
=
¥

Z 100

X size

Y size

7 size
L

|
# of slices
L

|
Transparency

Black Level 185

Done Help

0
I Use 3dmod Black/White
False color

Click on “Use

3dmod

Black/White”

(to change the
image brightness/
contrast to match
the original data)

13. In the Movie/Montage window, click Set Start, then Set end, to remove the

rotation settings.

Full 360 ¥ | Full 360 ¥ | ™ Long way
Set Start | SetEnd | ™ Reverse
|-77.96 |-77.95 X Rotation
| 151.4 |151.4 ¥ Rotation
|-27.45 |-27.45 Z Rotation
|-1339 |-1839 X Translation
| -2082 |-2082 ¥ Translation
| -59 | -53 Z Translation
|511.5 |511.5 Zoom Factor
[1 [1 X Slice
1 1 Y Slice:
100 1 Z Slice
|0 |0 Transparency
| 1 | 1 Thickness
100 # of movie frames
2 3: # of montage frames in X &Y
Make Save as
* Movie * TIFFs 20 El: FPg
" Montage " IPEGs
¥ write fles | PGS Sequence...
Make | Stop | Done | Help |

14. Set Start to a Z slice where your model is fully
visible, and Set End to a Z slice where your model

is not yet visible.

15. In the Sequence window, click “Add After”.
Then Run All. (see yellow box in step 11).

godify the

. Jdmodv Movie Sequencen.,. — O

table

x

Add Af‘ter‘ ."-'.ddBEfDI’E‘ Replace ‘ Delete ‘

Actions that use settings in current table segment

Use as Mavie ‘ Set to Start ‘ Set to End |
| # Frames |‘-"iew# | Label
1 100 1
Run Al Save ‘ Load | Done | Help |
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16. Go to View > Window size. This will bring out the size of your Model
View window. Now resize your Zap window to match the Model View one.

B 3dmo.

Size of Model
View window

Size of Zap window |

3dmod ZaP Window: nodules34flip_ali_trim1.mrc

08 Resizer — |

Set window size:

Wid

17. In Model View, go to
Edit > Controls

[ set dipping planes farther out
I

|

Mear dipping i}

Far dipping 1000
|

|

Perpective 1]

Z-scale
—Rotation

il W | X-axis I 0.00
il W | Y-axis I -3.58
il W | Z-axis I 0.00

StartfStop Rotation |

™ Link to top Slicer angles

¥ Link centers of rotation
il 'l I 35 degfsec

Step (degrees) 1.0

Done | Help

18. In the Zap window, hold the
right mouse button to move the
image to match the Model View
image as closely as possible (look
at the position of structures on
the edges for guidance).

>

Match the Zoom factor of the
Zap window to the Scale shown
in the Controls window.

od ZaP Window: nodules34flip_ali_trimT.m
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18. Go to File > Movie/Montage.

IES
3d d: dules... _ O Y . Axis to Control
. rod: nodules 19' Set' Cx Cy &z € Tme
File Edit Image Special Help [
Mew Model aflip_ali_trim1_modely 1~ Start 1
Open Mol - Z Start and End to match ‘ -
! i
Reload Model <[ =] j==s| | those used for the model. — 1
Save Model S v |194E|—;| /5195 Rate: ﬂ ﬂ [20.0 Fps
Save Model As... T . 100 Actual FPS: 7.58 (avg) 8.70
Write Model A » H/ Snapshot format to the same Looping
" S Mode . . " Round trip % One way
Movie/Montage... I ~ e || Used for model view images ———
Set SHEFI Dir... — " None + Startfend
Gray TIF Snaps Auto| | ' Model (eg JPEG) " Current pt
& JPEG
Mernory to TIF... ol
! 17 PNG
Extract File... F z' E——
Process File... [ Montage by [2 =
Save InfoiExt e I™ whole image at 1:1 zoom
™ Scale sizesby | Auto
Quit
Slicer montage snapshots

™ Montage by |2 3:

I scale thickness by | Auto =

Reset | Done | Help |

21. Keep Movie/Montage window open, and make sure
3dmod is on Movie mode.

22. Click with the right mouse A

nodules34flip_ali_trim1_modelv 1~
4] 2] |7 show button on the b(?ttom left of
the screen to “hide” the

Object [1 /1 x 2880 = f4596
Contour [~ /65 ||¥ [1840 =] /5195 selection cursor.
Point | z[1 =] j100
Black ——————— |— 195 ldads
White —————— | 236
[ Float [ Subarea  Auto " Model
zap: S'aving image to ... \Movie Snaps for ﬂ
instructions\zap099.jpg
DONE! j

23. In the Zap window, move to the Z position that you set as the Start in
Movie/Montage, then click anywhere on the image in the Zap window to
start saving snaps. You should see activity appearing on the Movie/Montage
window — this is an indication that it is saving snaps in the correct directory.

Now check that you have “zap” snaps saved in the folder you set as Snap Directory. This
should be the same folder used for the “Model” snaps, and the Zap snaps should be
immediately after the “modv” snaps. If the Zap snaps are not there, make sure you did
step 2, and then repeat step 23.
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24. Open Imagel (or Fiji) — or to download, go to https://imagej.nih.gov/ij/

Ji 25. Go to File > Import > Image Sequence.
" h
g p=df

4 Imagel - X
Edit Image Process Analyze Plugins Window Help
New Alx|olr) alels]o]#] | |
Open... Ctrl+Q  jght click to switch)
Sttt openiien | csnio 26. Go to the Movie Snaps
pen Samples
Open Recent : folder, select the first file. Click
Image Sequence...
Close Ctrewy | AW Open
Close All Ctrl+Shift+W LUT.. [£) Open Image Sequence... X
Save Ctrl+S e Look in: [ Movie Snaps for instructions s e®meE-
Text File...
Save As 4 fo
Revert Ctrl+r | eSS
Table...
Page Setup... URL
PiTi Ciistp Stack From List...
Quit TIFF Virtual Stack. ..
AV
XY Coordinates. ..
modv0006 modv0007
Exif Data...
NIFTI-Analyze Fie name: [modvoo00 -l Open |
Files of type: [ Fies ) ~|

A

27. Click OK and wait for the full image sequence to be loaded.

d Sequence Options x 4 imagel — X
File Ed'rtProcess Analyze Plugins Window Help

Number of images: Egg Type Jﬂ Q J|®|/}| | |»

Starting image: |1— e , ltch)

Increment: I‘l T Show Info... Cirl+l - = x|

140 Ctrl+Shift+P

-

Dev

Properties...

Scale images: [100 %

| Color b
File name contains: I [ies
Stacks 4

(enclose regex in parens) 5 Hyperstacks D
I~ Convertto RGB I Ciop Crl+Shift+X
v Sortnames numerically / ERCate Cirl+Shit+D
[~ Use virtual stack fj Rename...

Ctri+E
512 x 511 x 300 (299 4MB) Flip Horizontally
Flip Vertically g
Eansl He'pl ‘ Flip Z

Rotate 80 Degrees Right
Rotate 90 Degrees Left
Rotate...

" Translate...
" | Bin__

Press play p» to give you

’ Image to Results

an idea of what the \‘ y Resuts o mage

movie will look like.

Use the bar at the bottom of the image to check that
the zap snaps are now at the start of the image
seqguence, rather than at the end.


https://imagej.nih.gov/ij/

28. Go to File > Save As > AVI

{ Imagel — ®
Edit Image Process Analyze Plugins Window Help
New |Ala]@l0] afmfsle]s] | |»

Open... Ctrl+O

Open Next Ciri+Shift+O |

Open Samples 4

Open Recent

Import
Close Ctri+W
Close All Cirl+Shift+W
Save Ctrl+S

Tiff...

Gif ...
Revert Ctr+R

Jpeg...
Page Setup... Text Image...
Print._ Ctri+P | zp__
Quit Raw Data...

mage Sequence...
g
. BMP.. 4
o PNG.. ‘
" PGM.
5 HTS..
LUT...
Selection....
XY Coordinates...
Resuilts...
Text...

TIP: You might
want to change
the frame rate
(some users
prefer it slower
than 20 fps).

29. Click OK.
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ii Save as AVl...

Compression: |JPEG -
Frame Rate: E fps

Cancel

*

30. Select the file name and destination folder and click Save.

Imagel will then save an .avi movie file of your image sequence. The end!

To give you an idea of what you should obtain with this tutorial, watch the

end product on:

https://www.youtube.com/watch?v=0uGgcRtEFLc

TIP: To convert the file to .mp4 and compress it, you can use the free
software HandBrake - https://handbrake.fr/

Feeling adventurous???

B 3dmodv Movie: no..  — | X

Full 360 | Full 360 Y | I Long way

Set Start SetEnd erse

You can position your model in the model view window at
what you would like to be the start and end of a movement,
then press Set Start and Set End to define these positions as
start an end. Then click Add After / Add Before in the Movie
Sequence window. This allows you to produce snaps for any
sequence of movements of your model, which may even
include changes in transparency and zoom factors!

76.8 76.8 ¥ Ratation o
[182.2 [182.2 ¥ Rotation
|-31.15 |-31.15 Z Rotation
|-1839 | -1839 X Translation
|-2962 | -2982 ¥ Translation
-59 -59 7 Translation
5115 5115 Zoom Factor /

¥ Slice

[W]n] ac £
1] 0 Transparency
g

100 # of movie frames

2 El: # of montage frames in X &Y

Make Save as

+ Maovie {+ TIFFs —:|2-:- e
" Montage " IPEGs

. ST
¥ wirite fies EUEE Sequence..,
Make | Stop | Done | Help |

B 3dmodv Movie Sequencer..  — O x
Actions that madify the table
I Add After | Add Before I Replace | Delete |

Use as Movie |

Actions that use settings in current table segment

Set to Start | Set to End |

1 100

| # Frames |View# |

Label
1



https://handbrake.fr/
https://www.youtube.com/watch?v=OuGgcRtEFLc

